Problem in Cargo Transfer

I seem to have a problem with the cargo on the fleet not being able to be transfer onto the planet. I tried it at 2 different planet’s with the same result that it won’t transfer.

1 Like

Odd, I just did it with no problems. Clicked the Farsu (from your example), then max, then send.

It looks like the fleet is holding more cargo than it should(?)

Can you unload and reload? Are you upgrading ships? Did you split a fleet?

1 Like

That’s how much space he has left for Beron, which he clicked on the planet already (1301).

Last time I had something like that happen it was a because a troopship got blown up. I showed the fleet (sans any troopships) having something like 12831 troops with room for 0. It wouldn’t let me drop the troops it thought the fleet still had. I forget what made the problem go away but really I guess the stuff was not there.

Basically when I had the funds I upgraded the ship’s to be able to hold the capacity. Then transfered the cargo. Then upgraded them to what I wanted. It happened due to splitting fleets and reforming new groups of fleet. So I guess if you are going to be doing splitting of fleets. As precaution you unload all cargo , troops and colonists. To ensure that this doesn’t occur. Maybe there needs to be a caution message when upgrading ship’s or splitting fleet’s to transfer cargo, troops and colonists. At least when it comes to upgrading ship’s that the system checks for cargo, troops and colonists capacities between the existing design and the upgraded design. If the capacity isn’t enough in the upgraded design that the ship doesn’t upgrade. And simply a message stating that Upgrade can not be achieved due to lack of capacity of Colonists / Troops / Cargo. Stating which one’s haven’t the capacity. I do understand that the game is still pre-beta and problems like this will show up. So it is just a suggestion for how the problem can be solved. As you can see I solved the problem myself by upgrading to a design to hold the capacity needed.

1 Like

Thanks, I’ve created a bug for this. I haven’t been able to reproduce it yet myself, so if anyone finds out how to reproduce it please let me know.

If your wanting to try and produce it. You need to fill a cargo ship then upgrade dropping the level of cargo it can hold. Without transfering any of the cargo before you upgrade. To fix the bug the programmers need to code in that if the ship is being upgraded to another design that it checks between the two designs to see if the cargo-personnel-Troops numbers can fit into the upgraded design.

There should have been a similar report from A3 or skirmish. I don’t recall which of us it occurred with, but this did happen before.

Whoops just manged to do this myself!

Split fleet, merged one split into a new one, realised remain fleet had cargo and attempted to empty it and this happens:

The Frigate fleet above staunchly refused to unload or load cargo until I reversed the fleet back to its original composition then unloaded it.

I think what happened when I split I got a fractional point of cargo which rounded up and overflowed the capacity, not sure.

1 Like

Yes the 2 ways that this problem occurs is

  1. from upgrading ship’s to a different design that has less cargo capacity.
  2. from splitting fleet’s changing the cargo capacity of the fleet by splitting away ship’s that have cargo capacity.

For the moment to avoid this bug. It is essential before splitting fleets or upgrading ship’s that you transfer cargo/personnel/troops and ordinance to another Fleet or Planet.