Minefields cause huge performance loss

  • What happened
    Minefields makes the map perform poorly. My fps dropped to oblivion.

  • What were you doing at the time
    Just looking at space and my 19 minefields most of them overlap with one or more minefields. All of them are Tier 1 fields.

  • When did this happen
    It happened after I started to create my minefield network.

  • Is this the first time it happened
    Yes, it is.

It doesn’t matter what setting I use (low, medium, high)
Turning off volumetric fog and V-sync do not improve it whatsoever.

It is really bad. :crying_cat_face:

2 Likes

Nothing drops fps as much as minefields.

This is now true yet back in Alpha 2 it was not the case.

Following this post I fired a couple more up making a total of 6 and yeah each one cost me Fps. Though once upon a time I had a ring of them around my A2 empire some 200 LY in diameter and never saw a fps hit.

Wonder what changed?

I dont have a fps problem, at least not that i noticed, but my game is quite jumpy. If I zoom out or in, my window pans as well. I’ll zoom into the center of my empire and my window will move to the edge for example…

One of the devs will look into this shortly, thanks for reporting it.

1 Like

If you type show_debug_info into the console (hit the backspace ` key to open/close it, hide_debug_info to get rid it again) and then minimize it, you’ll have an in-game FPS counter you can keep your eye on.

I’m not sure I understand what’s going on. It sounds like the behaviour you see when moving the cursor to the edge of the screen and screen edge scrolling activates. Is this happening in windowed mode?

Would it be possible to make Low graphics settings not show those mine clouds with all those little floating mines floating around?

I am pretty sure those little mines are the reason for my low FPS. If I don’t have any of them on screen I have 100 FPS but with all of my fields on screen my FPS plummets to 12-15 :frowning:

I use tier 1 mines and I am playing as Mankind (If that makes any difference)

I have 10 100% density and 10-15 10% density fields.

Framerates ok for me still but if I zoom in on a minefield… CRASH!

I’ll make the suggestion. Thanks for the additional info, it will be looked at shortly.

I can see a few minefield related errors in the logs but haven’t reproduced it yet. Does it happen consistently for you?

1 Like

Not consistently no. Seems slightly higher when I zoomed into a field thats actively being formed maybe?

I have tried to zoom directly into and out of mine fields as well as other test with 0 success to reproduce the bug. It used to be somewhat regularly before the patch. I guess its possible my conputer had some issue with what was changed in the patch? I am at a bit of a loss.