Koret 3 is a Null Black Hole

I’ve submitted many bug reports. More screens are in discord. Adding a post.

I have

  • Verified Integrity of game files
  • Restarted
  • Reinstalled client
  • Reverified

On load, client loads null error about planets.

Event, I think:
I was offline, or in a phase where the server had kicked me but the client was still open? Not sure which I was in when, a neighbour colonized / dual popped one of my open planets. Upon reloading the client, the system is a black hole.

  • Mouseover the system title results in ui null errors. Eventually the client crashes.
  • Zooming into the system results in null error loop and crash. I never see a planet, just a black void.
  • No population or border are visible on system anymore (bc it is null serverside?)
  • But my neighbour seems fine.
  • Playing with other planets eventually does some kind of planet update and things explode again
1 Like

To me, it looks like the callstack has most recently called Game.Planet.get_HistoryOwnerPlayerId() and gets a null object reference.

something here is missing. probably because I was offline. But it exists for the new owner of the planet.

I on the other hand cannot open the client without errors. Mouseover the system, get more. Open system for full on loop of errors and crash.

I see a couple more things when I open the system:
Client.PlanetCustomHintComponentUpdate() seems to be part of the loop, and I think it is mainly the UI exploding from an uncaught null for … ownership ? history of ownership?

I’ll post the screenshots off discord that Praetor posted last night.
@joe

one

three

1 Like

What became of the ship you sent there?

It is beyond the system’s event horizon. There was a colo in there, a fluffy scout that went in after, and the catnip transport was diverted to help elsewhere. I assume the first two are just sitting in the system

1 Like

Galaxy Overview list with ally planets selected

Since the name is blue, not green as you would expect after having your ally use a colonizer to dual pop your planet, we tried cancelling our NAP to see if that would reset the who - owns - what bits.

But it didn’t work as the entry in the planet history list is null and things still explode.

Thanks for letting us know. I checked this on our test environment earlier today and got the same error immediately after entering the galaxy. One of the devs is looking in to it. I’ll let you know when I hear back from them.

2 Likes